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How to Download the 
MT4/MT5 Video

https://youtu.be/TFbhqXG32MU
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•	 On the Dashboard of you BDSwiss Profile, on the Accounts tab, click on Add new 
account and the list of the accounts types will open 

•	 Click on Classic Account and then Forex MT5 Live 

•	 Select the account currency and then enter and confirm your password to create 
the new account

How to Add a MT5 Account

Note: To trade DMA Stocks and ETFs on the MT5 
you need to add the InvestPLUS Account
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•	 You will find your MT5 Login details on the Accounts tab on the BDSwiss 
Dashboard  

•	 Open your MT5, select ‘Login to Trade Account’, then fill in your MT5 account ID 
and Password (the same used to register the BDSwiss account) 

•	 The server should already be filled in by default  
- BDSwissGlobal-Server01 for BDS Markets

Login
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If you have problems logging into the MT5 desktop platform, after confirming that all 
login details are correct (Account ID + Server + same password used in the BDSwiss 
account), and that you have downloaded the MT5 platform from our website, please 
follow the below instructions:

•	 ‘File’ > ‘Open an Account’

Login Issues
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•	 A pop up window will open where you will see the List of Brokers > Select the 
correct Entity of your account and then choose ‘Connect with an existing trade 
account’, fill in the details and click Finish

Login Issues

Note: Password reset only needs to be done if you are still 
unable to login after these steps
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•	 You can open or close it by pressing 
the hotkeys ‘Ctrl + M’ or from the menu 
click ‘View’ > ‘Market Watch’  

•	 You can choose from Forex, 
Commodities (metals and energies), 
Indices and Cryptocurrencies and you 
can search through the symbols by the 
first letter with the keyboard. 

•	 The Market Watch gives you the 
ability to observe price changes on 
instruments in real-time 

•	 Right-click on the Symbol > ‘Chart 
Window’ or drag the Symbol with the 
mouse to the chart window to see the 
graphical representation of the price 
movement.

The top left window is called the Market Watch, where you’ll find a list of assets 
available to trade on the MT5 platform and the Bid and Ask prices.

Market Watch
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Symbols

To see all the symbols to trade you simply need to click on the button       on the 
standard toolbar or : 
 
	 A. Right-click anywhere inside the Market Watch window and click on 	
	      ‘Show All’ 
 
	 B. Or, press ‘Ctrl + U’ and a new pop-up window will open where you can 	
	       add the symbols manually

A. B.
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Specification

In the MT5 platform, open the Market Watch 
window, press ‘Ctrl+U’ or right-click on the 
asset you want to check the details of and 
select ‘Specification’.

This pop-up window allows to view 
the contract specifications. The main 
parameters are the following:

Digits – the amount of digits after decimal 
point in the price representation;

Contract size – one-lot price in deposit 
currency;

Spread – difference between Bid and Ask 
prices;

Stops level – minimum distance to the 
current price in points at which Stop Loss 
and Take Profit orders can be placed;

Hedged Margin – funds necessary to open 
and support an open hedged position;

Margin rate:
Initial – security deposit (margin) to perform a one-lot trade;
Maintenance – minimum security deposit (margin) to maintain a one-lot position;

Minimal/Maximal volume – lowest and highest lot allowed per trade;

Swap type – rollover calculation type (in points or in percentage);
Swap long/short  – rollover size for a long/short position;
3-days swap – information about the day of the triple rollover fees;

Sessions – quotes and trading schedule.
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•	 Press ‘Ctrl + U’ > Bars - Choose a time range and timeframe to see the Historic Data 
of Bars (Open, High, Low and Close)

      - You can save this information in  an Excel.cvs file by clicking on the ‘Export Bars’ 	
        button at the bottom

•	 Press ‘Ctrl + U’ > Ticks - Choose a time range to see the Historic BID and ASK prices  
of a symbol

      - You can save this information in an Excel.cvs file by clicking on the ‘Export Ticks’              	
        button at the bottom

Bars and Ticks
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Chart

The top right window is called the Chart window. 

The charts show the price movements of an asset over a specific time frame (hourly, 
daily, weekly etc). 



14Trading involves high risk of losing your money. Any information provided shall be for information purposes only

Chart Toolbar

1.	 Open chart 

2.	 Change the chart type - bar, candlesticks or line 

3.	 Zoom in and out of the chart 

4.	 Arrange windows as non-overlapping tiles 

5.	 Auto Scroll / Chart Shift 

6.	 Save the active chart data as picture

3 41 2

Timeframes Toolbar 
(add it by going to View > 
Toolbars > Timeframes)

5 6
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Customize Colors

You are able to fully customize charts to your preferences by pressing F8 or right-
clicking on the chart window > ‘Properties’ > ‘Colors’
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Ask Line

The MT5 chart shows the BID (sell) line by default. The ASK price line is not visible on 
the Chart. 

To add the ASK line you need to press F8 or right-click on the chart window on the  
MT5 > ‘Properties’ > ‘Show’ > tick the box ‘Show ask price line’ > OK
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Navigator

In the Navigator window you will be able to see, in tree from, the list of open Accounts 
(and be able to switch between them), Indicators, EAs, Scripts and Services.

•	 You can open or close it by pressing the hotkeys ‘Ctrl + N’ or from the menu click  
‘View’ > ‘Navigator’



18Trading involves high risk of losing your money. Any information provided shall be for information purposes only

Toolbox

The Toolbox is where you manage and monitor your trading, open trades and pending 
orders, and check details such as your trading Account History, overall Balance and 
Equity, and Margin.

•	 You can open or close it by pressing the hotkeys ‘Ctrl + T’ or from the menu click 
‘View’ > ‘Toolbox’ 
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New Order

To open a position, at the current market price - Market Execution, click the button                   
on the standard toolbar or, on the Market Watch window, right-click on the desired 
symbol and select ‘New order’ or press the F9 hotkey on the Chart window. A new pop-
up window will open and you can set the volume of the trade in lots, the Stop Loss and 
Take Profit, and then click on the Sell or Buy button (A.)

You can also enable the One Click trading on the chart by clicking ‘Alt + T’ where you 
simply select the volume of the trade (no S/L or T/P is set) and click on the SELL or  
BUY button on the top left corner of the chart (B.)

A. 

B.
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Pending Order

If you want to place an order, not for immediate execution, but for when a certain  
price point has been hit - Pending Order. 

You will have 6 options:

•	 Buy Limit – If you plan on going long at a level lower than the market price 

•	 Sell Limit – If you plan on going short at a level higher than the market price 

•	 Buy Stop – If you plan on going long at a level higher than the market price 

•	 Sell Stop – If you plan on going short at a level lower than the market price 

•	 Buy Stop Limit – As soon as the ASK price reaches the Stop Limit price indicated  
in the order window, a Buy Limit order will be placed 

•	 Sell Stop Limit – As soon as the BID price reaches the Stop Limit price indicated  
in the order window, a Sell Limit order will be placed

You can also leave the Expiration of the order as GTC (Good ‘til canceled)  
or set it to a specific date and time
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Depth of Market

The Depth of Market window allows you to zoom in on the tick chart price levels and 
place orders within the same window.

•	 Right-click on the chart window and select ‘Depth of 
Market’ or press ‘Alt+B’ to open the Depth of Market 
window.

•	 To place a Market Execution order, 
set the volume, Stop Loss and Take 
Profit, and click the Sell or Buy 
button. 

•	 You can place a Pending order by 
clicking on the arrows: 
 
-If you click above the price level 
you are placing either a Sell Limit or 
a Buy Stop order 
 
-If you click below the price level 
you are placing either a Sell Stop or 
a Buy Limit   order
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Modify Position

•	 On the Toolbox right-click on the desired order and then click ‘Modify or Delete’ 

•	 Or, double-click on the desired order and and select Modify Position on the Type 
drop down list on the pop-up window. 

      - The SL and TP can be modified by price or points  

•	 Click on the Red Modify button to save the changes
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Invalid S/L or T/P

If you are unable to open a trade and you receive the error message Invalid S/L or T/P:

•	 Right-click on the asset on the Market Watch window > ‘Specification’ > ‘Stops level’ 
and check the distance, from the actual price, that the S/L and T/P needs to be 
placed.
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S/L and T/P Lines

If you place a trade with S/L and T/P and you cannot see the selected levels line on 
the MT5:

•	 Make sure that you have this option enabled by pressing ‘Ctrl + O’ or going to 
‘Tools’ > ‘Options’ > ‘Charts’ > click ‘Show Trade Levels’ > ‘Enable or Disable 
dragging of trade levels’ > OK
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Trailing Stop

•	 Right-click on the desired order on the ‘Toolbox’ > ‘Trade’ window and then click 
on the ‘Trailing Stop’ option  

•	 A list of options will open, where you can select your desired distance between 
the TP level and the current price or customize it.  

•	 The Trailing Stop works in the terminal, not in the server (like SL or TP) - It will 
not work if the terminal is off. In this case, only the Stop Loss level that has 
been set by the Trailing Stop will be triggered. 

•	 Trailing Stop is processed once per tick. If multiple orders with Trailing Stop 
are open for one symbol, only the trailing stop of the latest open order is 
processed.



26Trading involves high risk of losing your money. Any information provided shall be for information purposes only

Partial Close

To Partially Close a Position, double-click on the position and a new pop-up window 
will appear where you can select the Volume you wish to close and then click on the 
yellow Close button.
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Close Position
•	 Right-click on the desired order and then click on the ‘Close Position’ option (1.) 

•	 Or, double-click on the desired order and the pop-up window will appear where you 
can then click on the yellow Close button (2.)

•	 Or, simply click on the cross in the Trade Tab in the Toolbox window:

1.

2.
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Hedging
BDSwiss offers a MT5 Hedging Account.

A Hedging Account allows you to open multiple positions on the same symbol, 
including opposite directions. 

The example below shows the execution of two 0.5 lot trades in GBPUSD 
simultaneously:

Note: BDSwiss does not offer Netting Accounts

•	 There is no limit for the number of positions you can hold at the same time 

•	 Positions are opened one after another.  

•	 Your current position doesn’t change. 
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Hedging
On Hedging Accounts you can close a position by an opposite one at a single symbol.

Compared with a single closure of the two positions, the closing by an opposite 
position allows traders to save one spread:

To Close By an apposite trade:

•	 If the opposite positions have different numbers of lots, only one order of the 
two remains open. Its volume will be equal to the difference of lots of the closed 
positions, while the position direction and open price will match (by volume) the 
greater of the closed positions.

•	 In case of a single closing, traders have to pay a spread twice: when closing a sell 
position at a higher price (Ask) and closing a buy position at a lower one (Bid). 

•	 When using an opposite position, an open price of the second position is used 
to close the first one, while an open price of the first position is used to close the 
second one.

1.	 Right-click on the desired trade and select ‘Modify or Delete’ 
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Hedging
2.    A new pop-up window will open where you change the Type to Close By

3.    Then, a new window will open to let you select the trade you want to use 
        to close by
  
         -  After you select it, you can then close it on the yellow Close button
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History
To view the MT5 trading history go to the ‘Toolbox’ > ‘History’ tab at the bottom. 

•	 Right-click within to choose the time period 
- Click on Report to save a copy of your trading History
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Trade History
You can choose to see a visual representation with arrows of your Trade History by 
right-clicking on Chart and then clicking on ‘Trade History’ on the list
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Alerts
•	 To create a price Alert you need to go to ‘Toolbox’ > ‘Alerts’ > right-click and select 

‘Create’ 

•	 A new pop-up window will open where you can fill in the details such as Action 
(sound, email, etc.), Expiration date, Symbol, Value, etc. and you can Test it and click 
OK to set it. 
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Alerts
•	 Or, select the price on the chart, right-click > ‘Trading’ > ‘Alert’

•	 Once the Alerts are set, you can manage them on ‘Alerts’ Tab on the Toolbox 
window:
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Drawing Tools
You can access the MT5 drawing tools (i.e. Lines for support and resistance,  
crosshair, Fibonacci etc.) by clicking on the buttons on the Line Studies toolbar:

•	 Or, by going to Menu > ‘Insert’ > ‘Objects’ and choosing the desired object from 
the list:

•	 Right-click on the chart window to select the Objects List or press ‘Ctrl + B’ and a 
pop-up window will open where you can change the parameters of your Objects 
on the Properties, and also Delete them.
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To Add Technical Indicators to your chart:

•	 Go to the Menu > ‘Insert’ > ‘Indicators’ and choose the desired Indicator from  
the list (1.) 

•	 Or, drag and drop Indicators from the Navigator window (2.)

Technical Indicators

1. 2.

Note: Once you click on the desired Indicator 
a new pop-up window will open where you can 
change the parameters to your preferred ones

You can Download Technical Indicators that are not available by default on the MT5.

•	 You can download them directly on the MT5 platform on the ‘Market’ section on 
the Toolbox window and then you will see them on the Navigator window under 
the ‘Indicators’ > ‘Market’ 

•	 Or, you can download the Indicators from other sources: 

1.	 Download the files (.ex5 and .mq5 formats) 

2.	 Add them on the MT5 by going to ‘File’ > ‘Open Data Folder’ > ‘MQL5’ > paste 
or drag the Indicator to the ‘Indicators’ Folder 

3.	 Close and restart the MT5 

4.	 You will then be able to see the new Indicators on the Navigator window 
under the ‘Indicators’ directory and on ‘Insert’ > ‘Indicators’ > ‘Custom’
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To Delete Technical Indicators:

Technical Indicators

•	 Right-click on the desired Indicator on the Chart window and a pop-up window 
will open, then select Delete Indicator (1.) 

•	 Right-click on the Indicator window (technical indicators like Oscillators for e.g. 
are opened in a separate window) and a new pop-up window will open, then 
select Delete Indicators Window (2.) 

•	 Or, right-click on the chart window, select the ‘Indicators List’ or press ‘Ctrl+I’ 
and a pop-up window will open where you can change the parameters of your 
Indicators on the Properties, or Delete them (3.)

1. 2.

3.
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•	 You can create Profiles of assets you would like to trade by setting up a group of 
charts of your preferred assets (with different timeframes, indicators, etc.) and then 
click on ‘File’ > ‘Profiles’ > ‘Save as’ > ‘Enter new profile name’ > OK or by clicking the 
button           on the standard toolbar.

•	 To Load the new profile, you can go back to the Menu > ‘File’ > ‘Profiles’ or click on 
the ‘Profiles’ button            and then click on the name of the desired profile.                      

•	 To Delete a profile you need to go to the Menu > ‘File’ > ‘Profiles’ > ‘Remove’ or click 
on the ‘Profiles’ button           > ‘Remove’ and then click on the profile you want to 
delete.

Profiles
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Templates

1.	 Open a new chart > Apply all the indicators and settings you wish to use on 
that chart 

2.	 Go to the Menu > ‘Charts’ > ‘Templates’ > ‘Save Template’ (A.) or right-click 
on the chart window and, on the list, select ‘Templates’ > ‘Save Template’ 
(B.) > ‘Name the Template’ > Save

1. 2.

If you want the template to be the default 
one for every new chart you will need to 
name the template as Default

You can create Templates that allow you to overlay predefined indicators and other 
adjustments (ask line, different candle colors, etc.), to a chart. Creating a template 
allows you to load these predefined settings instead of having to set it up again each 
time you open a new chart.
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Templates
•	 To Load a template you need to go to the Menu > ‘Charts’ > ‘Templates’ or right-click 

on the chart window and select ‘Templates’, then click on the name of the desired 
template on the list or click on ‘Load Template’ to choose from the templates folder. 

•	 To Delete a template you go to the Menu > ‘Charts’ > ‘Templates’ or right-click on the 
chart window and select ‘Templates’ on the list, then click > ‘Remove Template’.
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Algorithmic Trading or automated trading is making buy and sell operations using 
trading robots. In the trading platform, these programs are also called Expert Advisors 
or EAs.

To add an EA, you need to:

To enable an EA, you need to:

Algorithmic Trading

1.	 Add it on the MT5 by going to the Menu > ‘File’ > ‘Open Data Folder’ > ‘MQL5’ 
> paste or drag the EA to the ‘Experts’ Folder 

2.	 Restart the MT5 and you will be able to see it on the Navigator under ‘Expert 
Advisors’

1.	 Go to Menu > ‘Tools’ > ‘Options’ or press ‘Ctrl + O’ > ‘Expert Advisors’ > ‘Allow 
algorithmic trading’ 

2.	 Enable Algo Trading on the standard toolbar:
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1.	 Go to the Navigator window > ‘Expert Advisors’ and you will then be able to add 
the EA by dragging and dropping it on the chart window or by right-clicking on it > 
‘Attach to a chart’ 

2.	 Confirm or change the EA inputs and, once you finish, you will be able to confirm if 
it’s enabled on the ‘Experts’ tab on the Toolbox window

Algorithmic Trading

4

3

Disabled Enabled

You will also be able be able to confirm if 
the EA is enabled or not by the symbol on 
the right-top corner of the chart window
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Algorithmic Trading
To change the inputs or remove your EA(s):

•	 Right-click on the chart window, select the ‘Expert List’ and a pop-up window 
will open to allow you to make the changes on the inputs of you EA on the 
Properties, or Remove it:
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Strategy Tester
The Strategy Tester allows you to test and optimize Expert Advisors and Indicators 
before using them. 

•	 To open the Strategy Tester window go to the Menu > ‘View’ > ‘Strategy Tester’ 
or press ‘Ctrl + R’  

•	 The Strategy Tester window will open below the Toolbox window

•	 You will be able to adjust your preferences on the Settings tab and parameters 
on the Inputs tab:

•	 Click on the Start button in the bottom right corner to start testing
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•	 Show / Hide OHLC (Open, 
High, Low, Close) 

•	 Bar Chart 

•	 Candlestick Chart 

•	 Line Chart 

•	 Zoom In / Out 

•	 Full Screen 

•	 Next Chart Window 

•	 Tile Windows 

•	 Close Chart Window 

•	 Crosshair 

•	 Show / Hide Grid 

•	 Show / Hide Tick Volumes

•	 Market Watch 

•	 Show / Hide Symbol 

•	 Navigator 

•	 Toolbox 

•	 New Order 

•	 One Click Trading 

•	 Depth of Market 

•	 Properties 

•	 Options 

•	 Object List 

•	 Indicator List 

•	 Strategy Tester

Ctrl + M

Ctrl + U

Ctrl + N

Ctrl + T

F9

Alt + T

Alt + B

F8

Ctrl + O

Ctrl + B

Ctrl + I

Ctrl + R

Ctrl + H

Alt + 1

Alt + 2

Alt + 3

+ / -

F11

Ctrl + F6

Alt + R

Ctrl + W or Ctrl + F4

Ctrl + F

Ctrl + G

Ctrl + L

Shortcuts

Risk warning: Trading in Forex/ CFDs and Other Derivatives is highly speculative and carries a high level of risk. It is possible 

to lose all your capital. These products may not be suitable for everyone and you should ensure that you understand the risks 

involved. Seek independent advice if necessary. Speculate only with funds that you can afford to lose.

BDS Markets is an investment firm, incorporated in the Parliamentary Republic of Mauritius (Company Number: 143350) and 

is authorised and regulated by the Financial Services Commission of Mauritius (FSC) under License Number: C116016172. 

Registered address: BDS Markets, 6th Floor, Tower 1, Nexteracom Building 72201 Ebene – Mauritius. Please review the 

company policies regarding the regulation

BDSwiss.com is operated by BDS Swiss Markets Global Services Ltd which is the primary payment provider and website 

operator. BDS Swiss Markets Global Services Ltd is acting on behalf of its related company, BDS Markets.

For complaints please email us at: complaints@bdswiss.com
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